Doctors already believe that erectile dysfunction is an early warning sign of heart problems, but it's not clear why. Presence of viagra for women generic alternatives in online australia may greatly help in favour of brand viagra for women. Its easy to find out how to buy viagra for women online australia without rx. With help of online pharmacy viagra for women cost easy to get for every men with no bulls benefits in quality. Carrying extra pounds can impact your sexual performance, and not just by lowering your self-esteem. Obese men have lower levels of the male hormone testosterone, which is important for sexual desire and producing an erection. Being overweight is also linked to high blood pressure and hardening of the arteries, which can reduce blood flow to the penis.Pharmaceutical companies must maintain high ethical standards when conducting promotional activities and comply with applicable legal, regulatory and professional requirements. Visiting website of online pharmacy in malaysia is the best method to find out how to purchase clomid in malaysia cheap. If you buy generic alternative of clomid its cost is often less. Ethical promotion helps to ensure that healthcare professionals have access to information they need, that patients have access to the medicines they need and that medicines are prescribed and used in a manner that provides the maximum healthcare benefit to patients.

Announcement

Collapse
No announcement yet.

2 out of 4 tower speakers not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2 out of 4 tower speakers not working

    Have 4 horn tower speakers on my 2014 210. Just noticed that only two are working. I'm pretty good at electrical but haven't really messed with audio that much. Any idea where to start? Pic of Amps below. I also struggle from hissing speakers like many others but decide not to go down that wild goose chase
    Attached Files

  • #2
    The amp on the left looks like your 4 channel that is for the tower. The one on the right looks like a 1000.1 which would be for your sub. Weird that just 2 dont work. I would pop the back of the can off of the speakers that dont work and note the color wires. Then find them out of the amp and make sure they are tight. You could then swap them with one that works to test. It is likely that they are blown. I cooked mine the first year of my 2015 g21. I swapped them with these. https://wetsounds.com/pages/products/REV696RS. They where way louder and can handle more power.

    Comment


    • #3
      it would actually be a 5 chnl, not a mono, for the woofer AND in-boats.

      Non the less, polk 4 chnl does drive the tower. Are the two speakers out on the same side or one on each side of the tower?

      Could be balance in the head unit. RCA connection either at the head or the amp, bad amp. Could be two blown speakers, bad connections at the pods, pinched wires in the tower. A simple volt/ohm meter can be a huge asset.

      Comment


      • #4
        Originally posted by MLA View Post
        it would actually be a 5 chnl, not a mono, for the woofer AND in-boats.

        Non the less, polk 4 chnl does drive the tower. Are the two speakers out on the same side or one on each side of the tower?

        Could be balance in the head unit. RCA connection either at the head or the amp, bad amp. Could be two blown speakers, bad connections at the pods, pinched wires in the tower. A simple volt/ohm meter can be a huge asset.
        Uh, im pretty sure if its a PA D1000.1 which is what it looks like than its a single channel sub amp. Could be wrong though. I would be interested in more info if I am.

        Comment


        • #5
          The setup looks very OEM, especially with the 3 deutsch style connectors that carry the tower, in-boat, woofer and turn-on circuits. ive not know of a correct craft of that generation, to have an OEM woofer without an amp for the in-boats. Ive also never seen CC to use the PA D1000.1.

          The dimensions of the D5000.5 and D1000.1 are nearly identical, so they do look similar against the smaller D4000.4

          Comment


          • #6
            Did check and yes itís a D50005.5, hoping to dig into the issue more tonight


            Sent from my iPhone using PLT Nautique

            Comment


            • #7
              Seems to be fixed. One of the two may be blown as can only hear a little instrumental and no vocals. However the other one is working. Adjusted the balance from the head unit in the glove box instead of the drivers seat. Could have been that or fiddling with wires around the amp*♂️. Good enough for me!


              Sent from my iPhone using PLT Nautique

              Comment


              • #8
                Originally posted by Jakeb View Post
                The amp on the left looks like your 4 channel that is for the tower. The one on the right looks like a 1000.1 which would be for your sub. Weird that just 2 dont work. I would pop the back of the can off of the speakers that dont work and note the color wires. Then find them out of the amp and make sure they are tight. You could then swap them with one that works to test. It is likely that they are blown. I cooked mine the first year of my 2015 g21. I swapped them with these. https://wetsounds.com/pages/products/REV696RS. They where way louder and can handle more power.
                Were you able to install these inside the same factory enclosures? Have any pics? Im looking to replace my roswell horn drivers on my tower as they sound terrible.

                Comment


                • #9
                  Yes they fit without the grill.... Not the quality photo
                  Attached Files

                  Comment

                  Working...
                  X