Announcement

Collapse
No announcement yet.

HELP GT40 2001 SAN surging after running high RPMs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Peter6000
    replied
    Originally posted by Danny Roberts View Post

    Which lines should I be checking? Sorry I'm not familiar with the entire fuel system with the FCC and all
    There are only 2 vacuum lines from the intake manifold to the MAP sensor and to the fuel pressure regulator.
    A bad fuel injector could be the problem you can test these without removing them.
    Use a fuel pressure tester to monitor pressure and turn ignition on
    Pressure builds up to 36psi or so
    The pressure should stay above 30 for at least a few minutes or you have a leaky injector.
    Now you need a external 12v source and connect it to the first injector for 1 sec.
    The pressure will drop a certain amount.
    The drop should be the same for all injectors.
    Or run the engine and use a stethoscope to listen to each injector if on is not kicking it's bad.

    Sent from my SAMSUNG-SM-G870A using Tapatalk

    Leave a comment:


  • Aaren22
    replied
    I have this same boat and had the same problem. I threw a bunch of parts at it and it ended up being a clogged fuel injector

    Leave a comment:


  • Danny Roberts
    replied
    Originally posted by Peter6000 View Post
    I would start by checking fuel pressure
    If OK check all sensors and idle air bypass valve and clean throttle body while you on it.
    Check the vacuum lines.

    Sent from my SAMSUNG-SM-G870A using Tapatalk
    Which lines should I be checking? Sorry I'm not familiar with the entire fuel system with the FCC and all

    Leave a comment:


  • Peter6000
    replied
    Originally posted by Danny Roberts View Post
    2001 GT40 is "surging" after running at high rpms for no longer than 5 minutes. The more the rpms the sooner the problem appears. It will run all day fine at a lower rpms (say below 3000). So far replaced relays, fuel filter, plugs cap & rotor. Any ideas? No engine lights, all fluids are fine. Next step i can think of is anti siphon valve on tank, fuel lines, and then high pressure fuel pump. Its almost like the engine is "starving" for fuel at a higher rpms or under load.
    I would start by checking fuel pressure
    If OK check all sensors and idle air bypass valve and clean throttle body while you on it.
    Check the vacuum lines.

    Sent from my SAMSUNG-SM-G870A using Tapatalk

    Leave a comment:


  • HELP GT40 2001 SAN surging after running high RPMs

    2001 GT40 is "surging" after running at high rpms for no longer than 5 minutes. The more the rpms the sooner the problem appears. It will run all day fine at a lower rpms (say below 3000). So far replaced relays, fuel filter, plugs cap & rotor. Any ideas? No engine lights, all fluids are fine. Next step i can think of is anti siphon valve on tank, fuel lines, and then high pressure fuel pump. Its almost like the engine is "starving" for fuel at a higher rpms or under load.
Working...
X