Announcement

Collapse
No announcement yet.

07 Nautique - completely dead up front - only manual bilge switch working!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 07 Nautique - completely dead up front - only manual bilge switch working!

    Hi all - got a PCM 330 in last week, boat stood for 5 years - both batteries completely dead.. Put 2 new group 24s in - dash dead - no LED or anything coming up on the HUD.. Checked all fuses at batt switch - all good, red breaker power on both poles. Manual bilge switch at dash works - but nothing else. I removed the black box beneath driver dash - and the fuses are all in - however, the POS and NEG terminals have no power - does the thick red cable from the fuse box get power from the red breaker on the motor?

    I fiddled with the main control, the kill switch is in and wires connected- could standing for 5 years fry the ecm? So far ive checked 2 large inline fuses off battery switch, both battery switch terminals working, and also a large 30 amp fuse - all working. COuldnt find any other fuses to check apart form the main box
    Last edited by FranZ28; 1 week ago.

  • #2
    Is the 3 position toggle switch on the starboard side panel near the throttle in the “ON” (up) position? If so, with the switch in the “ON” position I would use your VOM and test for power into and out of the switch. It is possible you just have a bad toggle switch.

    Comment


    • #3
      will check and update thanks!

      Comment

      Working...
      X