Announcement

Collapse
No announcement yet.

1995 sport hesitating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chris from Oz
    replied
    The temp gauge goes just above half then drops a touch, but the water temp is cool at the moment as we are coming out of winter. During summer the water temp is very warm so it may be better without? There is a company not far from here that service pcm engines and they said it should have one? The engine is an injected Gt40. I removed the fuel tank today to check it out and empty it. Not much fun. Glad I did as there was a lot of black debris in the bottom. There is a large black rubber ring at the base of the fuel intake inside the tank which was not sitting correctly and blocking one of the holes at the bottom of the intake. I’m hoping this was restricting the fuel flow as well as the possibility of old fuel. I will put it back in tomorrow and put some premium fuel in and cross my fingers. The boat came from Sacramento California, not sure if it’s near the ocean but I’d say it has been in salt water as there is a bit of rust and corrosion around the engine. Hope to take it out in a week or so and test it again. Thanks for the response.

    Leave a comment:


  • chefred112
    replied
    how warm does your boat get. When I bought my supersport a few years ago it had a tendency to run warm I decided to run without the tstat because I live out here in Cali and the weather stays pretty mild.. Yes, There's a chance you could have old/bad gas gas. I'd try to pump some out and use some premium for awhile to see if it changes anything. Is your boat fuel injected with the gt40?

    Leave a comment:


  • Chris from Oz
    started a topic 1995 sport hesitating

    1995 sport hesitating

    I have a 95 sport nautique which is running out of power and hesitating at 30 MPH, I reached 37 MPH on initial take off. The fuel has been in the tank over winter about 6 months so was wondering if this could cause this problem? The filter is brand new. The boat starts and runs great. I have also just put a thermostat in it as it was missing? not sure if this is common.
Working...
X