Announcement

Collapse
No announcement yet.

2001 Air Nautique Check Engine light

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2001 Air Nautique Check Engine light

    Yesterday I replaced the cap, rotor, wires and plugs on my 2001 Air with the GM based 5 Liter (305cdi). I took it out for a test drive and after I got up to speed the check engine light came on. It did not go into limp mode and the temp gauge stayed right at 140 Deg. I suspect I may have disturbed something while routing the plug wires but canít. find anything. Any ideas?


    Sent from my iPad using PLT Nautique
    Life's good on HEIRNAUT!!!

  • #2
    The engine light only comes on for a few things... temp, oil pressure, oil level and drive fluid level (I think).

    Considering your temp gauge seemed fine, check your oil pressure when running.

    If that's ok, more than likely it is your oil pressure switch. Its on the side of your block below the exh manifolds... t-fitting with a few sensors sticking from it.

    Should look like this http://www.nautiqueparts.com/product...-tec-and-gt40/

    Easy to check if that's the faulty sensor. Just disconnect the wire from the end and your check engine light should go out.

    Comment


    • #3
      Originally posted by 2001 Python View Post
      The engine light only comes on for a few things... temp, oil pressure, oil level and drive fluid level (I think).

      Considering your temp gauge seemed fine, check your oil pressure when running.

      If that's ok, more than likely it is your oil pressure switch. Its on the side of your block below the exh manifolds... t-fitting with a few sensors sticking from it.

      Should look like this http://www.nautiqueparts.com/product...-tec-and-gt40/

      Easy to check if that's the faulty sensor. Just disconnect the wire from the end and your check engine light should go out.
      Thanks, Iíll give that a try. Much appreciated


      Sent from my iPad using PLT Nautique
      Life's good on HEIRNAUT!!!

      Comment


      • #4
        I really appreciate your help. I disconnected the wire an the light did not com back on. I'll install a new one this week and should be good to go.
        Life's good on HEIRNAUT!!!

        Comment

        Working...
        X